June 27, 2001

Up To Here

I’m sick of coming across sites that don’t support Internet Explorer 5 for Mac. So I’ve decided to start complaining:

Greetings. I visited your web site today and to my dismay found that it was inaccessible with Internet Explorer 5 for Macintosh. Please know that Internet Explorer 5 for Macintosh is the browser of choice for a wide array of Mac users, many of whom will not switch to another browser simply to accommodate the shortcomings of a handful of “incompatible” web sites. Excluding these loyal Mac users who choose to surf with the best Mac browser on the market hurts business via traffic, word-of-mouth, and in the end, profit. Please let me know when you’ve chosen to support web standards to the point of supporting Internet Explorer 5 for Macintosh. Until then, please refrain from sending me any messages. Thank you.

And I encourage you to do likewise. At any site which doesn’t support your browser. Especially if that site is iWalt.com (which currently supports IE 5 Mac and Netscape 6 best, most browsers well, and Netscape 4 and OmniWeb hardly at all.)

Previous Post
Next Post