October 3, 2004

Spots

Spotty images.

This is a photo I took of the sky on a clear day. I’ve called out a few areas of the photo to show at full size. As you can see there are three very noticeable spots. I’ve tried cleaning the lens and using a blower (very gently) on the low-pass filter. That’s pretty much all I can think to do and the spots are driving me nuts. Any suggestions?

[Update: So I’m hoping that this turns out to be a bit of dust on the sensor and that I can find someone trustworthy to give it a swipe. Thanks for the feedback.]

Previous Post
Next Post

Comments

Garrett

See these two items:

http://www.nikonians.org/dcforum/DCForumID86/2320.html http://www.photo.net/bboard/q-and-a-fetch-msg?msg_id=008iOT

Other than this issue, how are you liking the camera? I’m seriously considering the D70 right now.

Bryce

UFOs dude. UFOs.

Walt

Bryce: =-)

Garrett: I had seen that first link before and it scared the crap out of me but the second link sounds extremely helpful and there’s even a link buried in the thread about DIY sensor-cleaning. (I’m not sure I’m ready for that yet but it’s interesting.) What I should probably do is check it with a different lens and then think about whether I was to clean it myself or find out whether this falls under the warranty.

Other than this the camera is amazing. I am not worthy of its greatness. =-)

Brian Poulsen

Walt - Try to go to the store you bought the camera in, or find some kind of local camera repair center. It’s not unusual to get dust on the sensor. Most stores - repair centers anyways, can blow the dust away with an air blower or some kind.

Walt

Thanks Brian, I’m going to see if a shop I like in Santa Rosa can do the job the next time I’m up there. I appreciate the feedback. The spots were really bothering me but I’m getting confident that it’s not such a big deal.

Sian

I had a similar problem with my Digital Rebel/300d and initially thought I had dust on the sensor. I purchased a lens pen and a cleaning cloth and it got rid of the spots. It’s well worth investing in a set of cleaning equipment before sending the camera in for repair!

Smudge is on the top right hand corner http://www.pbase.com/webdivauk/image/33222270

Sian

Duh! forgot to mention I used the kit on my lenses.

Walt

Thanks for the suggestion. I have tried cleaning my lens a couple of times and I’m pretty sure it’s not to blame. If I get the opportunity to check the camera with an alternate lens I will just to make sure. Your issue looks pretty similar to mine. What’s a “lens pen” btw?